Help your participants save time and access Easy LMS from a single account. You can configure Okta for the Academy portal. Here's how!

Single sign-on is available with the Enterprise Owl plan. At this time, only the previous Academy interface supports SSO. Please contact support@easy-lms.com to be placed on this version.

Step 1. Create an app for Easy LMS

From your Okta administration environment, go to Application > Add Application to add a new application.



Select Create New App to create an app for the Easy LMS integration.



Name the new application anything (e.g., Learning environment or Easy LMS). For the Login redirect URI, add the URL of the Academy and login. This is the URL from the Academy login page:





Step 2. Configure the SSO settings in Easy LMS

In Easy LMS, go to My account > Advanced setup > Single sign-on. Select the Azure / Okta / Auth0 tab.



Fill in the following fields with this information:

title: Okta
provider_url: You can find this in Okta under the Sign-On tab of the newly created application under OpenID Connect Token in Issuer. The URL should look something like https://your-okta-account.okta.com.



client_id: You can view this in Okta under the General tab of the newly created application. Go to General > Client Credentials > Client ID. The client_id field in Easy LMS corresponds to the Client ID located in Okta:



client_secret: You can also view this in Okta under the General tab of the newly created application. The client_secret field in Easy LMS corresponds to the Client Secret located in Okta:





When the fields are filled, remember to hit Save!

Step 3. Change the login method for the Academy

In Easy LMS, go to Academy > Settings. The Login method for Academy should be set to Single sign-on through OpenID Connect.

If this setting is missing from your account, it means you are on the new Academy interface. Contact support@easy-lms.com to be switched over to the version that supports SSO.



Step 4. Verify the settings

Go to the Academy and see whether you are required to log in using Okta. Everything has been successfully set up when that works!
Was this article helpful?
Cancel
Thank you!